SchemaTheek
 
Home Nieuws Forum Schema's Artikelen Magazine Downloads Links Shops Zoeken
 
Controle Paneel
Gebruikersnaam
Wachtwoord
  Onthoud mij
» Wachtwoord?
» Registreren
Site info
» Het Team
» Contact
» FAQ
» Leden
» Upload Archief
Stats
Totaal online: 18
18 gasten
0 leden:
Forum > Diversen > Proton IDE probleem?
pascalbianca
Lid
Berichten: 1394
Gepost op zaterdag 28 December 2013 08:55:35 QuoteWijzig

Ik heb 2 versies van Proton IDE op mijn pc, namelijk de Lite versie en de gewone versie.
Als ik in de Lite versie de volgende code zet is er niks mis.:

Code
Device 16F648A                                   

Xtal = 20
All_Digital TRUE                                  

'TRIS sequence 7-6-5-4-3-2-1-0
'1 = input and 0 = output
TRISA = %00100000    '                              
TRISB = %00001110    '                             

Dim Var1 As Byte
          
Hserial_Baud = 9600        ' Set baud rate to 9600
Hserial_RCSTA = %10010000  ' Enable serial port and continuous receive
Hserial_TXSTA = %00100000  ' Enable transmit and asynchronous mode 
Hserial_Clear = On         ' Optionally clear the buffer before receiving

Loop:
'HSerIn , Timeout , Timeout Label  ,  Parity Error Label , [Modifiers , Variable {, Variable... }]
HSerIn , 1000 , Timeout , [Var1] ' Receive a byte serially into VAR1
If Var1 = 11 Then
 'send i2c command to mcp23008 but i don't know how to write the code.
EndIf
Timeout:
GoTo Loop ' Loop forever
End



Maar zet ik deze code in de normale versie , dan krijg ik bij .:
Code
HSerIn , 1000 , Timeout , [Var1] ' Receive a byte serially into VAR1


De foutmelding.: ERROR [Line 30]: Value Expected! (xxxx.bas)

Hoe kan het zijn dat de lite versie (beperkt) hier geen probleem mee heeft?

De lite versie is 1.0.0.1 en de gewone is 2.0.0.5

http://pascalbianca.blogspot.nl/
Stynus
Admin
Berichten: 2773
Gepost op zaterdag 28 December 2013 10:49:18 QuoteWijzig

Die eerste komma moet weg.


Code
HSerIn 1000 , Timeout , [Var1] ' Receive a byte serially into VAR1



De syntax veranderd helaas met de compiler versies een beetje. (Ik heb versie 3.5.5.5 , daar is het nog veel strikter.)


Met vriendelijke groet, Stynus ||| www.elektronicastynus.be
pascalbianca
Lid
Berichten: 1394
Gepost op zaterdag 28 December 2013 11:12:14 QuoteWijzig

Thx Stynus, hij geeft nu geen fout melding meer, stom dat daar verschil in zit,


http://pascalbianca.blogspot.nl/

Active Topics

» Subaru Outback 2016
» Stofafzuiging
» Aanpassingen aanbouwde...
» Audi
» Show je mini projecten
» Puls schkelaar
» Draadknipper
» Intercom
» buske (Peugeot Boxer 2...
» Voeding 24V 3A Stynus

» Meer actieve topics

Advertenties

ElektronicaStynus

© 2004-2019 SchemaTheek
Laadtijd: 0.02694 sec.