SchemaTheek
 
Home Nieuws Forum Schema's Artikelen Magazine Downloads Links Shops Zoeken
 
Controle Paneel
Gebruikersnaam
Wachtwoord
  Onthoud mij
» Wachtwoord?
» Registreren
Site info
» Het Team
» Contact
» FAQ
» Leden
» Upload Archief
Stats
Totaal online: 23
23 gasten
0 leden:
Forum > Elektronica algemeen > Poort gaat uit zichzelf uit?
pascalbianca
Lid
Berichten: 1394
Gepost op zondag 7 September 2014 23:06:24 QuoteWijzig

Ik heb in menu staan dat de klep open of dicht gezet moet worden.
De klep heb ik op de relai vervangen voor een lamp.
Als ik dus in het menu kies dat de klep open moet gaat de lamp zeer kort branden en weer gelijk uit.
Dit kan ik natuurlijk oplossen door een delay erachter te zetten, maar nu komt dus mijn vraag......

Als ik toch zeg PORTD.6 = 1 blijft die toch op 1 totdat ik zeg dat hij weer 0 moet worden , deze doet hij toch niet uit zichzelf of wel?
Dit is de code die ik heb , waar hij dit bij doet (waar ; voor staat was eerst maar werkt niet)


Code
 
If counter3 = 2 Then
    PORTD.6 = 1
    DelayMS 3000
   ;high VijverWaterKlep
   ;DelayMS 3000
   ;low VijverWaterKlep
EndIf
         
If counter3 = 3 Then 
    PORTD.6 = 0
    ;Low VijverWaterKlep
EndIf



update

Probleem gevonden.
 
[Bericht gewijzigd door pascalbianca op Maandag 8 September 2014 09:34:18]

http://pascalbianca.blogspot.nl/
Er zijn nog geen reacties geplaatst.

Active Topics

» Inrichting laadruimte ...
» schema HK audio pro 21...
» Stroom verdeelbox 230V...
» Subaru Outback 2016
» Stofafzuiging
» Aanpassingen aanbouwde...
» Audi
» Show je mini projecten
» Puls schkelaar
» Draadknipper

» Meer actieve topics

Advertenties

ElektronicaStynus

© 2004-2019 SchemaTheek
Laadtijd: 0.01877 sec.